CTX103345
XenApp
XenApp 6_5 for Windows Server 2008 R2,XenApp 6_0 for Windows Server 2008 R2,XenApp 5_0 for Windows Server 2008
Connectivity
2016-04-15
2014-04-01
This article contains information to troubleshoot errors when using dsmaint to connect to the data store.

Symptoms or Error

When running the dsmaint config command with a specified username and/or password, the following error messages might appear:

“Attempting to connect to the data store with new configuration settings.
Failed to connect to the data store.
The settings will be reverted to the previous configuration.
Unable to change configuration settings.
Please verify parameters and data source.”

— or —

Under certain circumstances, you might be able to successfully run the dsmaint command, but when attempted to start the IMA Service, it might fail. The following error messages might appear in the system’s event viewer:

Source: IMAService
Event ID: 3612

Description: “The Citrix XenApp Server failed to connect to the Data Store IMA_RESULT_ACCESS_DENIED. Invalid database user name or password. Please make sure they are correct. If not, use DSMAINT CONFIG to change them.”

Source: IMAService
Event ID: 3609

Description: “Failed to load plugin ImaPsSs.dll with error IMA_RESULT_ACCESS_DENIED.”

Source: IMAService
Event ID: 3609

Description: “Failed to load plugin ImaRuntimeSS.dll with error IMA_RESULT_ACCESS_DENIED.”

Source: IMAService
Event ID: 3601

Description: “Failed to load initial plugins with error IMA_RESULT_ACCESS_DENIED.”

Source: Service Control Manager
Event ID: 7024

Description: “The IMA Service terminated with service-specific error 2147483670.”


Solution

Consider the following two options, when typing a username or password that contains a reserved character to resolve the error:

  • Enclose the reserved character with double quotes; for example:
    Dsmaint /user:m”&”f /pwd:m”^”frame

  • Precede the reserved character with a carat (keyboard keys: Shift+6); for example:
    Dsmaint /user:m^^&f /pwd:m^^frame

Note: Because the carat itself is a reserved character, to enter it as part of the username or password requires you to precede it with another carat or enclose it in double quotes.


Problem Cause

If the username or password specified contains a reserved character, the Windows command prompt does not treat the reserved character as plain text. Reserved characters include: & | ( ) < > ^


 

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