Symptoms or Error
When the setting KeyboardLayout=(Server Default) is configured in the default.ica file on a Web Interface site, that setting does not take effect for users connecting to a Virtual Desktop Agent from a Linux client.
Solution
Virtual Desktop Agent 5.6 Rollups XD560VDAWX86200 – CTX135455 –?? Rollup XD560VDAWX86200 (Version 5.6.200) - For Citrix XenDesktop Virtual Desktop Agent Core Services x86 - English?? and XD560VDAWX64200 – CTX135456 –?? Rollup XD560VDAWX64200 (Version 5.6.200) - For Citrix XenDesktop Virtual Desktop Agent Core Services x64 - English?? contain fixes that address the issue. After installing the rollup on the Virtual Desktop Agent, you must configure the rollup as follows:
Caution! This procedure requires you to edit the registry. Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Back up the registry before you edit it.
To force the setting above when connecting to a Virtual Desktop Agent from a Linux client, follow the steps below. The following example forces Japanese IME 2003 as the default keyboard on a Windows XP Virtual Desktop Agent.
1. Log on to the Virtual Desktop Agent as an administrator from the console.
2. Install the hotfix.
3. In Control Panel:
4. Under Settings, select Japanese - Microsoft IME Standard 2003 as the default input language and click OK to apply the change.
5. Open Registry Editor and browse to the following registry key:
-
????" On Windows XP: go to Regional and Language Options > Languages tab and click Details to open the Text Services and Input Languages dialog.
????" On Windows Vista, go to Regional and Language Options > Keyboards and Languages tab and click Change keyboards to open the Text Services and Input Languages dialog.
????" On Windows 7, go to Region and Language > Keyboards and Languages tab and click Change keyboards to open the Text Services and Input Languages dialog.
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layouts
6. Find the registry key corresponding to the keyboard layout identifier of Japanese IME Standard 2003. In this example, the ID is "e200411".
Note: The keyboard layout ID of Microsoft Office IMEs varies according to the install order. For example, if Office 2010 is installed before Office 2003, IME 2010 may have the ID "e200411".
7. Browse to the following registry key:
HKEY_USERS\.DEFAULT\Keyboard Layout\Preload
Name: 1
Type: REG_SZ
Data: <Keyboard layout ID from Step 6>
8. In Control Panel:
9. Restart the Virtual Desktop Agent.
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????" On Windows XP, go to Regional and Language Options > Advanced tab and check Default user account settings. Click OK to apply the change.
????" On Windows Vista, go to Regional and Language Options > Administrative tab > Copy to reserved accounts and check Default user account (new users). Click OK to apply the change.
????" On Windows 7, go to Region and Language > Administrative tab > Copy settings and check New user accounts. Click OK to apply the change.
Problem Cause
Due to a limitation of keyboard layout support for Unicode clients, in order to apply the setting, the expected default keyboard layout must be specified in the registry after installing the hotfix on the Virtual Desktop Agent.
Additional Resources
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CTX135455 -??" Rollup XD560VDAWX86200 (Version 5.6.200) - For Citrix XenDesktop Virtual Desktop Agent Core Services x86 - English
-
CTX135456 -??" Rollup XD560VDAWX64200 (Version 5.6.200) - For Citrix XenDesktop Virtual Desktop Agent Core Services x64 - English
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CTX135445 -??" Rollup XD560VDAWX86200 (Version 5.6.200) - For Citrix XenDesktop Virtual Desktop Agent Core Services x86 - Japanese
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CTX135446 -??" Rollup XD560VDAWX64200 (Version 5.6.200) - For Citrix XenDesktop Virtual Desktop Agent Core Services x64 - Japanese
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