CTX136669
XenApp,XenDesktop,StoreFront,NetScaler Gateway
Access Gateway 10,StoreFront 1_2,XenApp 6_5 for Windows Server 2008 R2,XenDesktop 5_6
Other
2016-04-14
2015-02-25
How to configure StoreFront to use SmartAccess through AGEE 10.x.

Symptoms or Error

When using SmartAccess for Access Gateway Enterprise Edition, the Access Control filters fail to apply when applications or desktops are delivered through StoreFront.


Solution

Complete the following steps to modify the StoreFront configuration to enable requireTokenConsistency:

  1. On the Citrix StoreFront server, open C:\inetpub\wwwroot\Citrix.

  2. Open the folder that represents the required App Store (example: Store1).

  3. Open web.config file using Notepad.

  4. Search for the requireTokenConsistency attribute.

  5. Change the attribute value - requireTokenConsistency="true".

  6. Save the changes.


Problem Cause

By default, the requireTokenConsistency attribute is set to false in the StoreFront application store.

Enable this setting to allow SmartAccess conditions to be passed from StoreFront 1.2 server to the XML brokers for XenApp or XenDesktop.


 

Join the conversation

Citrix Discussions

Open a case

Citrix Support

特别说明


本文来源为Citrix.com所有,翻译后版权归翻译者所有.如需转载请注明出处.

文档版本


.

广告招租


最新留言


.

广告招租


.