CTX200309
XenDesktop
Licensing
2016-05-03
2014-12-18
Citrix Director 7.6 Licensing Status Panel shows “Cannot Retrieve the Data” when upgraded to Citrix Director 7.6 from earlier versions. ...

Symptoms or Error

Citrix Director 7.6 Licensing Status Panel shows “Cannot Retrieve the Data” when upgraded to Citrix Director 7.6 from earlier versions.
User-added image

-On?? Director server getting following errors on the event viewer:

Failed to connect to the data source ?? 'Unknown error'
Verify that the data source is available??

User: 'Domain\user'
Console operation: 'Retrieving license server alerts data…'

Additional diagnostic information (error message):
'The server committed a protocol violation. Section=ResponseStatusLine'


Solution

Resolution 1

Open the Command Prompt or PowerShell and run the following:
C:\inetpub\wwwroot\Director\Tools\DirectorConfig.exe /upgrade

Resolution 2

  1. Edit??& the Web.config file from location C:\inetpub\wwwroot\DesktopDirector and change the "keepaliveenabled" field from true to false.
  2. Restart IIS.

Problem Cause

The XenDesktop Meta Installer is not using the switch/upgrade while upgrading Citrix Director as a result web.config of Director does not get updated with the required settings for a valid Licensing Status.

Note: This issue occurs only when Citrix Director is upgraded with other components of XenDesktop and not when only Citrix Director option is selected for upgrade in Meta Installer.


Applicable Products


 

Join the conversation

Citrix Discussions

Open a case

Citrix Support

特别说明


本文来源为Citrix.com所有,翻译后版权归翻译者所有.如需转载请注明出处.

文档版本


.

广告招租


最新留言


.

广告招租


.