CTX203256
2016-04-28
1970-01-01
This article helps solve an issue where the VDA goes into an Initializing state and unable to launch applications. Only a reboot of the machine fixes the ...

Symptoms or Error

Customer is having problems with VDA server, becomes unregistered and remains in an Initializing state. Restarting the services does not solve it and users are unable to launch applications from that VDA or other ones as they are seen as being on the Stuck VDA.

Solution

Found that the BrowserName for four applications had trailing spaces which was causing the VDA to go into an "OutofOrder" state. During tracing it was found that Database update/merge was failing due to this.

Remove the trailing spaces with the following Powershell commands:

- Get-BrokerApplication -ApplicationName "*" ??> C:\Apps.txt (Gets a list of applications)
- Open the txt file and look for BrowserName for each and see if they have trailing spaces
- Once you have a list of the applications do the following:
$app1 = Get-BrokerApplication -ApplicationName "<App Name>"??
Set-BrokerApplication -BrowserName "<App Name with no space>"??

Problem Cause

Customer is having problems with VDA server, becomes un registered and remains in an Initializing state. Restarting the services does not solve it and users are unable to launch applications from that VDA or other ones as they are seen as being on the Stuck VDA.

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