CTX207868
2016-04-27
1970-01-01
The following error is displayed when upgrading StoreFront from version 3.0.1 to 3.5: Error 1603: Fatal error during installation.

Symptoms or Error

The following error is displayed when upgrading StoreFront from version 3.0.1 to 3.5:
Error 1603: Fatal error during installation


Solution

Resolution 1

  1. Stop the World Wide Web Publishing service.
  2. Stop all?? StoreFront related services.
  3. Delete any sub folders under “C:\Program Data\Citrix\Storefront Install”.
  4. Open C:\Program?? Files\Citrix\Receiver?? StoreFront\Services\ProtocolTransitionService\Citrix.DeliveryServices.ProtocolTransition.ServiceHost.exe.config and within the .config file, change all lines where "Version=3.0.1.0" states to "Version=3.5.0.0".
    Save the config file and then run the Storefront 3.5 installation executable as an administrator.

Resolution 2

  1. Stop the World Wide Web Publishing service.
  2. Stop all?? StoreFront related services.
  3. Move the CtxsWebProxyIconCache from c:\inetpub\wwwroot\Citrix\StorenameWeb\App_Data\CtxsWebProxyIconCache\ to the root of C: and rename the c:\ProgramData\Citrix\Storefront Install\3.0.0.44 folder.
  4. Run the Storefront 3.5 installation executable as an administrator.
Notes:
  • The CtxsWebProxyIconCache is only an icon cache and gets recreated when a user logs into StoreFront.
  • If you have multiple servers in the Storefront deployment, you will need to do this on all of the machines.

Resolution 3

  1. Look for the following lines:
    <runtime>
    <generatePublisherEvidence enabled="false" />
    </runtime>??

  2. Remove the preceding lines from the following files. Ensure to back up the files before making any changes.
    C:\Program Files\Citrix\Receiver Storefront\ClusterManagement\Feature.config
    C:\inetpub\wwwroot\web.config
    C:\inetpub\wwwroot\AGServices\web.config
    C:\inetpub\wwwroot\Citrix\Authentication\web.config
    C:\inetpub\wwwroot\Citrix\xxxxxxStore\web.config
    C:\inetpub\wwwroot\Citrix\Roaming\web.config
    C:\inetpub\wwwroot\Citrix\PNAgent\web.config??

  3. Reboot the server and run the StoreFront 3.5 installation executable as an administrator.


Problem Cause

The files in c:\inetpub\wwwroot\Citrix\Storename\App_Data\CtxsWebProxyIconCache\ end up having a fully qualified file name of greater than 260 when copied to c:\ProgramData\Citrix\Storefront Install\3.0.0.44\Instances\InstanceId\App_Data\CtxsWebProxyIconCache which happens during the upgrade process.


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