CTX212277
2016-04-27
1970-01-01
XenMobile Auto Join WiFi option does not auto join and requires the user to manually select the WiFi network for the device to connect.

Symptoms or Error

XenMobile Auto Join WiFi option does not auto join and requires the user to manually select the WiFi network for the device to connect.

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In XenMobile 10 console > Configure > Device Policies > WiFi > deselected all platforms except for iOS > Provided a Policy Name >??Auto Join (automatically join this wireless network) set to ON:

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Solution

On the client device, forget the WiFi network and in WorxHome refresh the policy or redeploy from the XenMobile server.

If the preceding steps does not resolve the issue then, create a Profile Removal policy to remove the old Wi-Fi profile:

From XenMobile console, navigate to Configure > Device Policies > Add > More > Profile Removal > enter Policy Name and an optional description and click Next:

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Select the Profile ID associated with the WiFi network that is not Auto Joining as expected and enter an optional Comment and click Next:

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Select the Delivery Group such as AllUsers and deploy.

Recreate the WiFi policy and deploy it again to confirm whether the device will Auto Join.


Problem Cause

The WiFi network existed on the iOS device before XenMobile deployment and the XenMobile WiFi profile never updated the existing WiFi configuration with the Auto Join functionality. By performing a profile removal operation and then redeploying this WiFi network with no previous existing WiFi network of the same name seems to correct the issue.


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