CTX804493
Web Interface,Receiver,StoreFront
Receiver for Windows,StoreFront 2_0,StoreFront 1_2,Web Interface 5_4
Connectivity,Third Party
2016-04-20
2005-06-06
When launching an application from an ICA file, Web Interface or StoreFront through the Internet browser, users are prompted to save or download the ...

Symptoms or Error

When launching an application from the Internet browser, users are prompted to save or download the launch.ica file. The?? prompt Do you want to Open, Save, or Cancel the launch.ica connection file?? is displayed.The application does not launch immediately.?? Also, some but not all the users report that they are unable to connect.


Solution

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There can be a number of resolutions to the issue including but not limited to the following:

Install the Latest Version of Citrix Receiver

Install the latest Citrix Receiver version which can be downloaded from:?? Download Citrix Clients.

Add Website to Trusted Sites

Add the site to the Trusted sites list if using Internet Explorer browser using the following steps:

  1. Go to?? Tools?? > Internet Options > Security tab > Sites

  2. In the Add this website to the zone field, enter?? your organization's website and click Add.

  3. Repeat this for the?? .com,?? .net, .org, or .gov Web site addresses of your organization?? to allow the use of the ActiveX ICA client object for the launched connection to be?? automatically?? accepted.??
    Note: It might be required to also add any additional?? subdomain.domain.com URLs?? to the Trusted sites list in the Security?? tab setting if still experiencing unwanted prompts.
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Remove or Disable Third Party Browser Adware

Remove or disable any third?? party browser based Adware software that could be interfering with the successful launch of the ICA file. Restart the browser after removing these software and try again.

Clear the "Do not save encrypted data to disk" Option

If you are using Internet Explorer, click Tools > Internet Options > Advanced tab and clear?? the option “Do not save encrypted data to disk.”.?? This option?? should be cleared because the dynamic files are stored in the Temporary Internet Files folder. When applications are clicked, a file is downloaded to the folder, then launched using MIME type. If access to the folder is disabled or not available, the process cannot occur?? successfully.

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Automatically Open ICA Files

After the ICA file is downloaded, enable the browser to open similar files automatically.

  • Internet Explorer:?? Right click on the downloaded file and uncheck the option Always ask before opening this type of file.
  • Google Chrome: Click the drop-down list for the file in the download bar and select Always Open Files of This Type.

Associate .ica File Type With Citrix Connection Manager

  1. On Windows computers, go to Control Panel > Programs > ?? Default Programs > Associate a file type or protocol with a program.

  2. Under Name, find .ica file type.

  3. Ensure that the current default is set to Citrix Connection Manager. If not, click Change program and choose Citrix Connection Manager.

Disable ActiveX

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.??

Configure Internet Explorer as follows to allow successful application launching:

  1. Disable ActiveX filtering feature for the Web Interface site, either by:
  • Disabling ActiveX filtering globally:
    Click Gear icon, select Safety, de-select ActiveX Filtering. Alternatively,?? press Alt key and click Tools menu?? (ActiveX filtering is enabled if a “tick” appears next to it and is disabled if?? the “tick” disappears).

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    Or

  • Disabling ActiveX filtering for an individual site when ActiveX filtering is enabled globally:
    1. Log on to the Web Interface site and attempt to launch an application.?? At the end of the address bar a blue warning sign appears, indicating filtered content.

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    2. Click the blue warning sign and select Turn off ActiveX Filtering.
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  1. Enable ICA launch?? using one of the following options:
  • Add the site to the Trusted sites list: In the Security tab of Internet Options, add the Web Interface site to Trusted Sites list to allow the use of the ActiveX ICA client object for the launch.

    Or

  • Disable the MIME filter: Rename?? the following registry key: HKEY_CLASSES_ROOT\PROTOCOLS\Filter\application/x-ica

  1. Log off and?? close window then?? restart the browser after making this change.


Problem Cause

There can be a number of reasons for the issue including but not limited to:

  • The *.ica file on the client needs to be associated with a required installation of the Citrix Receiver.

  • The Internet Explorer browser option?? "Do not save encrypted data to disk"?? is selected in the Internet Settings on the Advanced tab.

  • A lockdown issue occurring after an upgrade of?? the current Internet Explorer browser version is preventing the launch.

  • The Web Interface server is not configured with the proper address routing or network address translation setting causing the launch.ica file to render with the incorrect local network IP address or https/SSL WAN address location.

  • Third party web browser based applications, known as Adware, or password caching shopping based programs installed on a client’s machine have been known to be the cause of this prompt.

  • The Citrix MIME types may not be configured correctly with ICA.


Disclaimer

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

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